HSL 2.0 building blocks issue

Visualisatie in EIB-KNX systemen, een vak apart.
Plaats reactie
charlez
Berichten: 173
Lid geworden op: do 28 feb 2013, 21:07

HSL 2.0 building blocks issue

Bericht door charlez » za 30 nov 2019, 11:25

Hoi,

Nog mensen die zelf hun Gira HSL 2.0 modules maken hier?

Heb mijn 1ste gemaakt, module werkt maar loop tegen enkele foutmeldingen aan, waar ik zo onmiddelijk niet kan achterhalen van waar ze komen.
Komen zowel in de simulator, als op hs zelf voor bij het starten.


HP 1820 PoE13902:5: SyntaxWarning: name 'hsl20_3_debug_page' is used prior to global declaration
HP 1820 PoE13902:99: SyntaxWarning: name 'hsl20_3' is used prior to global declaration
HP 1820 PoE13902:463: SyntaxWarning: name 'HP1820PoE13902' is used prior to global declaration


Iemand enig idee wat ik mis?

alvast bedankt

cevers
Berichten: 109
Lid geworden op: wo 03 jul 2013, 20:12

Re: HSL 2.0 building blocks issue

Bericht door cevers » wo 04 dec 2019, 18:39

Die 3 meldingen zijn normaal. Omdat je niet de rest van de homeserver opstart "mis" je een gedeelte van de python code. Je kan gewoon testen. Let wel op dat het testen voornamelijk voor de input en outputs zijn en dingen zoals http calls nog niet werken.

Is de module op de hs wel geladen? Kun je zien op de debug pagina hsl 2.0. Zou je moeten zien hoeveel er van draaien.

Edit: zie dat je ook die meldingen hebt op de hs?

charlez
Berichten: 173
Lid geworden op: do 28 feb 2013, 21:07

Re: HSL 2.0 building blocks issue

Bericht door charlez » wo 04 dec 2019, 19:28

Module werkt en Ja op hs heb ik de meldingen ook.

Zie de modules staan in debugpagina onder hsl 2.0

cevers
Berichten: 109
Lid geworden op: wo 03 jul 2013, 20:12

Re: HSL 2.0 building blocks issue

Bericht door cevers » wo 04 dec 2019, 20:45

debugerror.PNG
debugerror.PNG (7.7 KiB) 42 keer bekeken
Deze zie ik altijd als ik modules maak met simulator.pyc
Maar zie die meldingen niet terug in de HS. Misschien iets in je XML wat niet goed staat?

Daarbij opgemerkt dat ik meestal alles uit de gegenereerde XML weghaal wat ik niet gebruik zoals de logging.

charlez
Berichten: 173
Lid geworden op: do 28 feb 2013, 21:07

Re: HSL 2.0 building blocks issue

Bericht door charlez » wo 04 dec 2019, 23:24

Melding in hs is enkel zichtbaar bij opstarten net voor je het default scherm te zien krijgt.

Haal ook alles weg uit wat niet gebruikt wordt.

cevers
Berichten: 109
Lid geworden op: wo 03 jul 2013, 20:12

Re: HSL 2.0 building blocks issue

Bericht door cevers » wo 04 dec 2019, 23:52

Dan gok ik dat het een bug is. Merk iig geen invloed op de diverse homeservers. Alles draait prima en in hslist/debug geen foutmeldingen :?

charlez
Berichten: 173
Lid geworden op: do 28 feb 2013, 21:07

Re: HSL 2.0 building blocks issue

Bericht door charlez » do 05 dec 2019, 18:21

heb jij er een scherm aanhangen aan je hs?
Anders kan je dat natuurlijk niet zien...

cevers
Berichten: 109
Lid geworden op: wo 03 jul 2013, 20:12

Re: HSL 2.0 building blocks issue

Bericht door cevers » do 05 dec 2019, 19:18

Zal eens kijken of ik diezelfde melding krijg. Eigenlijk nooit een reden gehad om een scherm eraan te hangen.

Plaats reactie